Soon, we’ll be announcing a fresh new marketplace for TastyIgniter developers.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

PLEASE HELP! Website STOP working suddenly

Exclamation
#1 David12 Offline Junior Member
Hi Everyone!

Since many months the website was working perfectly.
And now without do anything the website stop working, so suddenly!

I can't access to the dashboard anymore, If you type the postcode the system doesn't work and you can't see the menu.
Customers can't register and access to it anymore, and when I insert the correct username and password of the admin on the login page nothing happen.

When I try to register a new account to test if it's working, I always get "The letters you entered does not match the image."
And when I type the postocode, I always see a blank page:  https://www.domainname.co.uk/local?location_id=11

GoDaddy is giving me this on the Logs:
[Thu Apr 12 06:00:35.110548 2018] [autoindex:error] [pid 590440:tid 139824193332992] [client 90.201.189.215:51940] AH01276: Cannot serve directory /home/tapeshprint/public_html/domainname.co.uk/admin/: No matching DirectoryIndex (home.html) found, and server-generated directory index forbidden by Options directive


How can i fix that? I can even provide the access to all the account if sameone knows how to help!

Thanks a lot Heart
#2 sampoyigi Offline 1 == 2
Check the solution here:
https://forum.tastyigniter.com/thread-55...ml#pid1996
#3 David12 Offline Junior Member
Thanks, Sampoyigi!
I have only one question because Tasty igniter is integrated on my website with an iframe.
And on my htacces I got a rule that redirect the home page index.php to a page call home.html.
As you can see here it's an iframe https://www.islandmixup.co.uk/order-now.html

This the main page: https://www.islandmixup.co.uk/index.php

Is this solution going to affect those links?


This is the htacess:

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.


# Prevent Directoy listing
Options -Indexes

<IfModule mod_rewrite.c>
# Turn on URL rewriting
RewriteEngine On

# !IMPORTANT! Set your RewriteBase here and don't forget trailing and leading slashes.
# If your page resides at http://www.example.com/mypage then use
RewriteBase /mypage

RewriteBase /
RewriteRule ^assets/downloads/(.*) not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>
# Begin Muse Generated redirects
# End Muse Generated redirects

# Provide Specific Index Page (Set the default handler)
DirectoryIndex home.html
#4 sampoyigi Offline 1 == 2
You'll only need to check the admin/.htaccess to make sure its properly configured since the main links are working except the admin dashboard.
#5 David12 Offline Junior Member
Thanks for your help,

this is the htaccess on admin

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.
Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

<IfModule mod_rewrite.c>
# Turn on URL rewriting
RewriteEngine On

# !IMPORTANT! Set your RewriteBase here and don't forget trailing and leading slashes.
# If your page resides at http://www.example.com/mypage/admin then use
# RewriteBase /mypage/admin

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>

I never changed even when i set up the website. Everything were working correctly for many months and now it's like this Sad
#6 Tanbir Offline Junior Member
At '# RewriteBase /mypage/admin'
Remove the #

Possibly Related Threads...

Thread / Author
URL
Last Post sampoyigi made 06 Apr, 12:28 PM
Forum Jump:

Users browsing this thread: 1 Guest(s)