Soon, we’ll be announcing a fresh new marketplace for TastyIgniter developers.

  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

TastyIgniter 3.X developer release

#1 Saravanan Offline Newbie
The Tasty Igniter team is pleased to announce the release of TastyIgniter 3.x, a complete rewrite from CodeIgniter framework to Laravel framework. 
This initial release is intended for developers only and is not for production use. 
You can download the version from the following link.

Download : TastyIgniter 3.X

We expect to provide several updates to this branch before the final production release. Please submit any bugs you find via Git. The earlier you submit them, the higher the likelihood that we can include the fixes in the final release.

we already have a group of great developers lending hand in the development support. If anyone is interested you can send request to join the group TastyIgniter Slack Channel
#2 mani Offline Newbie
Hi i recently run TastyIgniter 3.X version but i got following error

"production.ERROR: Symfony\Component\Debug\Exception\FatalThrowableError: Class 'ListController' not found in C:\wamp\www\TastyIgniter-dev-3.x\vendor\tastyigniter\flame\src\Traits\ExtendableTrait.php:132"

I click any menus (like user->customer..) show above error
#3 sampoyigi Offline 1 == 2
Check files permission?
#4 mani Offline Newbie
Hi sam i was run TastyIgniter 3.X through wamp server(windows platform) and how to check file permission?
#5 Caesium Offline Newbie
Im receiving the error below while installing. It occurs right after the ''Extracting TastyIgniter core'' message and ''Finishing Site Setup...'' remains with the loading icon.

Code:
{ "message": "Server Error" }
#6 samsonpauljr Offline Newbie
(09 Apr, 03:01 AM)Caesium Wrote: Im receiving the error below while installing. It occurs right after the ''Extracting TastyIgniter core'' message and ''Finishing Site Setup...'' remains with the loading icon.

Code:
{ "message": "Server Error" }

I am also receiving the same error as above;
#7 sampoyigi Offline 1 == 2
@mani @Caesium @samsonpauljr

The issue has been resolved.

It was related to linux case sensitive filenames which was stopping the ClassLoader from properly loading Classes.
#8 norter Offline Newbie
I have found errors during the installation of (dev / 3.x) .-

- setup/views/database.php
      - In to the input Port: name="host" -> name="port"

- In vendor the vendor/tastyigniter/flame/src/Filesystem/Filesystem.php the name of the folder is wrong (in servers with case sensitive fails) .-
      - vendor/tastyigniter/flame/src/FileSystem by vendor/tastyigniter/flame/src/Filesystem

- In vendor/symfony/translation/Translator.php there is a problem with line 79.-
      - public function __construct(?string $locale, MessageFormatterInterface $formatter = null, string $cacheDir = null, bool $debug = false) -> public function __construct(string $locale, MessageFormatterInterface $formatter = null, string $cacheDir = null, bool $debug = false)

PD: Sorry, I added it as an issue on github
#9 Caesium Offline Newbie
Receiving the following errors during extraction now;


Code:
Uncaught Error: Class 'Igniter\Flame\Filesystem\Filesystem' not found in /public_html/order/vendor/tastyigniter/flame/src/Foundation/Bootstrap/RegisterClassLoader.php:19 Stack trace: #0
Code:
/public_html/order/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(213): Igniter\Flame\Foundation\Bootstrap\RegisterClassLoader->bootstrap(Object(Igniter\Flame\Foundation\Application)) #1
Code:
/public_html/order/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(296): Illuminate\Foundation\Application->bootstrapWith(Array) #2
Code:
/public_html/order/setup/classes/SetupController.php(738): Illuminate\Foundation\Console\Kernel->bootstrap() #3
Code:
/public_html/order/setup/classes/SetupController.php(442): SetupController->bootFramework() #4
Code:
/public_html/order/setup/classes/SetupController.php(252): SetupController->completeSetup() #5
Code:
/public_html/order/setup/classes/SetupController.php(277): SetupController->o
#10 sampoyigi Offline 1 == 2
Issue has been resolved, you'll need to re-download the dev branch

Possibly Related Threads...

Thread / Author
Forum Jump:

Users browsing this thread: 1 Guest(s)