Soon, we’ll be announcing a fresh new marketplace for TastyIgniter developers.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Not Solved] Page goes white after i enter restaurant settings

#1 Luda Offline Newbie
After inputing restaurant settings, the page goes to a complete blanck page but having this address "http://localhost/tastyigniter/setup/index.php/settings"
Please help.

I have installed on localhost

My .htaccess files


root
<IfModule mod_rewrite.c>
    RewriteEngine On
   RewriteBase/
   RewriteRule ^assets/downloads/(.*) not_found [L]  
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>

admin
<IfModule mod_rewrite.c>
    RewriteEngine On
   RewriteBase/admin
   RewriteRule ^assets/downloads/(.*) not_found [L]
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>


setup
<IfModule mod_rewrite.c>
    RewriteEngine On
   RewriteBase/setup
   RewriteRule ^assets/downloads/(.*) not_found [L]
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>



config.php file

$config['uri_protocol']    = 'REQUEST_URI';

$config['index_page'] = 'index.php';



Database file

<?php  if ( ! defined('BASEPATH')) exit('No direct access allowed');

$active_group = 'default';

$query_builder = TRUE;

$db['default']['dsn'] = '';

$db['default']['hostname'] = 'localhost';

$db['default']['username'] = 'root';

$db['default']['password'] = '******';

$db['default']['database'] = 'tasty';

$db['default']['dbdriver'] = 'mysqli';

$db['default']['dbprefix'] = 'ti_';

$db['default']['pconnect'] = TRUE;

$db['default']['db_debug'] = FALSE;

$db['default']['cache_on'] = FALSE;

$db['default']['cachedir'] = '';

$db['default']['char_set'] = 'utf8';

$db['default']['dbcollat'] = 'utf8_general_ci';

$db['default']['swap_pre'] = '';

$db['default']['autoinit'] = TRUE;

$db['default']['encrypt']  = FALSE;

$db['default']['compress'] = FALSE;

$db['default']['stricton'] = FALSE;

$db['default']['failover'] = array();

$db['default']['save_queries'] = TRUE;

/* End of file database.php */

/* Location: ./system/tastyigniter/config/database.php */



I go through the requirements page but once i fill in the restaurant details (restaurant name and all that), it simply redirects to a blank page

PLEASE HELP
#2 Tanbir Offline Junior Member
You will need a space after the 'RewriteBase' in your .htaccess. EX: RewriteBase/setup ->should be -> RewriteBase /setup
#3 Luda Offline Newbie
Hi @Tanbir thanks for responding. I have done the changes but still no change. the same thing is happening


I am using PHP 7.0 (Just in case this information is important to know)


I was first using PHP 7.1 but I read in this from that for tastyigniter to work, we need to use PHP 7.0 or 5.6 so I installed 7.0


and still it's stuck on settings page
#4 Tanbir Offline Junior Member
Are you using PHP Version 7.0 or +?
#5 Luda Offline Newbie
I am using PHP 7.0
#6 Tanbir Offline Junior Member
Oh, thought it said MySQL 7.0 which got me confused a bit. If you are using TI v2.0 I recommend just deleting everything (backup any database you have) and re-downloading from https://github.com/tastyigniter/TastyIgniter
#7 Luda Offline Newbie
okay will try that and get back to you. Thanks

Possibly Related Threads...

Thread / Author
Forum Jump:

Users browsing this thread: 1 Guest(s)